Tag Archives: comcast

Your ISP’s DHCP does not function properly

As part of my migration to the cloud, I terminated the Comcast Business internet service and switched to Xfinity internet.

When I initially signed up for the Xfinity service, I got their cable modem / router / wifi appliance. My plan was to get my own cable modem eventually because Xfinity charges $13 / month to lease the appliance.

I was at Best Buy and saw that cable modems weren’t expensive, so I decided to purchase a mid-level model (Netgear CM600) so I could save the lease fee. The CM600 would pay for itself in about 8 months.

It took a while to get setup … and there were a few false starts, but eventually I got it working connected directly to my MacBook.

I ran into a problem when I switched the CM600 over to my ASUS RT-5300 wifi router.

I kept getting the message “Your ISP’s DHCP does not function properly” on the ASUS network map page.

Continue reading

New Internet Provider

Although it took more a lot longer to actually get around to making the change than I had planned on … I have finally switched Internet providers.

Previously I was using Covad for the midrange.com Internet service and AT&T for personal Internet service.

The Covad service was 1mb SDSL (1mb down / 1mb up with 5 static IP addresses) and the AT&T service was 6mb down & 768k up (ADSL).

The new service, provided by Comcast, is 22mb down / 5mb up and includes 13 static IP addresses.  It’s replacing both the Covad and AT&T service.

In addition to the improved speed, I’ll be saving about $50 / month in cost.

Continue reading

Positive Customer Service

Yes, it happens occasionally.

Once again it was with Comcast.

Well, at least partially.  This was a good recovery from a potentially bad experience.

Two weeks ago the picture on our cable was getting very pixelated … my first thought was that the TiVo was going bad, so I tried connecting the TV directly to the cable (using the digital tuner) and still saw the problem.

So I called Comcast customer service and scheduled a service call.  This was on Monday and the earliest service appointment they had was on Wednesday.  OK, we could live with crummy TV for a few days.

Tuesday we got an automated call from Comcast telling us that they had found a problem in our service and corrected it … and our service call had been canceled.  If we were still experiencing the problem, we should press “1” to be connected to customer service.

I checked the TV and, what do you know, it was working fine.  No pixelation.  Cool.  I didn’t have to leave work early on Wednesday to be here for the service call.

Continue reading

Utility Conundrum

I’ve got a bit of a conundrum about utilities … specifically, the Cable TV utility.

In the last few days Ginny and I had a major drainage issue in our back yard fixed.   We hired a landscaper to install drain tiles and pipe to collect water that was pooling in the back yard and route it into the storm sewer (they connected the sump pump to the same pipe).

Before the landscapers started, they called the J.U.L.I.E. service to mark all the utility wires to avoid interrupting service.

Late last week, J.U.L.I.E. came out and marked all the necessary parts of the lawn and the landscapers started their work.

Yesterday they finished the work and the lawn looks great.

Last night Ginny and I settled down to watch the premier of Warehouse 13 and were presented with a black screen with a message box floating around indicating that TiVo was searching for a signal on the cable.

Continue reading

New Tivo

We got a new Tivo box a few weeks ago … Tivo was running a promotion where you could buy a new Tivo Series 3 (HD) and transfer a lifetime subscription to the new box. As an added bonus, you could keep the old box running for a year.

Needless to say, it was not a hard decision. Although we currently do not have a HD TV, I suspect it’s just a mater of time before we get one.

The new unit arrived about 2 weeks ago … and I found a small problem. The new unit lacked the ability to control an external cable box via a RS232 cable. The old one had this ability. The new unit uses Cable Card(s) to decode & tune the cable signal. So I had to call Comcast to arrange to get a cable card (or two) installed. It took about a week to get Comcast out here … but they came out and installed a multi-stream cable card. Oddly enough, they arrived early and got the job done relatively fast.

Two nice things about using a cable card …

  1. No more ‘flip bar’ that shows up every time the cable box switches channels. That was really annoying to me, because Tivo already gave us much better information about the program we were about to watch.
  2. There are two tuners in the new Tivo and the multi-stream cable card will process two feeds at the same time. So we can record two shows at the same time.

The new Tivo has a few other nice features …

  • Built in RJ-45 network connection. We don’t have to use the USB. Of course I’m still stuck using wireless for the time being … at least until I figure out a way to get a wire from the basement to the wet-bar area.
  • It’s got an eSATA port … although it appears to only work with Tivo certified storage devices, we can theoretically upgrade the storage by just hooking up a external drive. I tried hooking up an eSATA drive that I had on hand, but it didn’t recognize it.
  • Although this isn’t really new to the Tivo, I was able to get an S-Video cable hooked up to feed the TV … and the quality difference is noticeable. Much better than the composite video we were using.

My only real gripe about the new unit is that the “Standby” button is gone. We used to push this button to put the unit to sleep … although it didn’t really go to sleep. It just shut off the audio & video feed to the TV. I can still put the unit into standby, but it takes 3 to 4 menu options to do it. If we don’t put the unit into standby, eventually it will automatically switch to live TV. Since we feed the audio through our stereo, that can be annoying.

Our options on this are to a) Use the menus to put the unit into standby, or b) mute the sound and turn off the TV while leaving the Tivo on. Neither is very handy. I called Tivo support and conveyed my disappointment.

Other than that, I really like the new Tivo. Maybe for the holidays Ginny and I will get a HD TV. The only big problem is that our current TV works fine. Oh well, maybe figure out something to do with it.

Of course now I have to figure out what to do with the old Tivo. 🙂