Category Archives: DSL

New Internet Provider

Although it took more a lot longer to actually get around to making the change than I had planned on … I have finally switched Internet providers.

Previously I was using Covad for the midrange.com Internet service and AT&T for personal Internet service.

The Covad service was 1mb SDSL (1mb down / 1mb up with 5 static IP addresses) and the AT&T service was 6mb down & 768k up (ADSL).

The new service, provided by Comcast, is 22mb down / 5mb up and includes 13 static IP addresses.  It’s replacing both the Covad and AT&T service.

In addition to the improved speed, I’ll be saving about $50 / month in cost.

Continue reading

Splitting the NID

For the past few weeks we’ve had a lot of static & interference on our home phone line … it doesn’t effect the Vonage line, so I figured it was coming from outside the house.

Well, it turns out the ‘NID Splitter’ we have in the phone box is giving out.     A NID Splitter is a device that plugs into the Network Interface Device that acts as a DSL filter for all the inside phone wiring.   A NID is the box where the telephone companies wiring interfaces with the house wiring.   Everything on the ‘Customer’ side of the NID is is your responsibility, anything on the other side of the NID is the telephone companies responsiblity.

It’s called a NID Splitter because it lets you split the phone line signal into two parts … one part that goes directly to the DSL modem, and the other half that goes to the house phone wiring.   The NID Splitter filters out the voice data on the phone line so it doesn’t interfere with the DSL signal.

Continue reading

A Series of Unfortunate Events

(with apologies to Lemony Snicket)

Last week was not all that great for me computer wise.

I had three events that pretty much threw me for a loop. If it hadn’t been for Ginny, I would have probably been a drooling, babbling, idiot.

Where should I start? Hmmm, the beginning, maybe?

(cue fade to memory music)

It all started the week before last … I was figuring out what to do with the week off between Christmas & new years. My linux servers (Gondor and Rivendell) are both running Fedora Core 4, and Core 6 was released a little while ago. I figured it would be a fine time to upgrade both servers.

The original plan was to upgrade the servers xmas eve, while Ginny was at church. That plan got changed, however, because Ginny didn’t want her churches website down over Christmas. Ok, later in the week would be fine.

So on Christmas eve, we went to my brother Mitch’s house for dinner. While there, Mitch showed me his Hauppauge MediaMVP . It’s a pretty slick device that lets you play videos (and music & pictures) on the TV. Since we have a SnapStream Beyond TV software running on a system in the basement, we have a lot of video files that can be played. Currently the only way we can play them is to hook up a laptop to the TV and play the videos that way. I figured it would be a nice addition to our A/V setup.

Christmas comes and goes … everything is nice, had a fun time we the family.

On December 26th, my friend Steve calls and asks if I want to take a trip down to Frys to see if they have any deals or specials going on. Sure I say, that could be fun. I’ve been wanting to get the wire to connect my Dell PE430SC server’s AUX_LED to the PCI IDE controller … just so I can see disk activity.

Since I wanted Steve to be able to help me find this cable, I opened the case to take pictures of the connectors. Got my pictures and proceeded to close the case. This is when the trouble happened. I accidentally bumped the ArcoIDE Duplidisk mirroring adapter. This must have caused a temporary problem because the unit started beeping as if one of the drives had failed. A drive hadn’t failed … but the drives were no longer in sync. Well, this shot the trip to Frys.

I spent the next couple of hours trying to figure out what what happened … and get the drives back in sync. I had to call Arco because there were problems getting the adapter recognized by the management software. I ended up attaching the primary hard drive of the mirrored pair directly to the ide controller. Rebuilding the mirror would have to wait a few days.

I decided to fix the mirror and do the Linux upgrade on Saturday the 30th.

I woke up bright and early on Saturday, fed the cat, fed myself, and went down to start my work.

First thing to do is get the mirror re-established. It took a bit of work, because I still couldn’t get the software to recognize the adapter. I determined that it was because the adapter was attached to a add-on PCI IDE card. When I hooked the adapter up to the motherboard’s IDE (it only has one), it worked fine. This is going to take 3 hours for the mirror to be rebuilt. It has to duplicate all the contents of the primary drive to the mirror drive.

While this is running, I started to do the upgrade on Gondor.

While the servers were down, I had setup a dummy “This site is under construction” page on another machine (shadowfax, for what it’s worth). My plan was to assign all the IP’s I have to that one machine so nobody would think my sites were just gone.

Got it all setup … but I couldn’t hit the dummy page. I figured it was because the DSL router still had the old machine’s mac addresses in memory. This has happened before. No problem, I telnet into the router and select the “Restart device” option. The device restarts … but then the 4 lights that correspond to the ethernet ports on the router start blinking at the same time … and the DSL light is not on. I try telneting to the router again, but get no response. I try using the RS232 connection to log into the router, but get no response. Nothing is working.

I also tried connecting my laptop to one of the ethernet ports on the router and notice that windows alternates between saying that my ethernet is Connected and The cable is unplugged at the same frequency as the blinking lights.

I call Covad and talk to a tech … it’s pretty quickly determined that the router had died. The earliest they can get someone out to replace the router is Monday the 1st.

Well, the midrange.com activity will be light because of the holiday … so I shouldn’t expect too many panic calls because there isn’t any list traffic.

So Sunday I decide to get the MediaMVP unit setup.

I had ordered it from amazon.com earlier in the week, but hadn’t had a chance to set it up. My original plan was to use my D-Link DWL-G730AP Wireless Pocket Router in client mode. In this mode I can connect a wired ethernet device to it and it connects to my wireless router.

Unfortunately, I couldn’t get the two devices to play together. Well, my boss had given me a $30 gift card for BestBuy, so I figured getting a wireless gaming adapter would be a fine use for it. I went to the Schaumburg BestBuy, but they didn’t have any wireless gaming adapters in stock at all. I then went to the Arlington Heights BestBuy and found they had one. The Linksys WGA54AG Game Adapter 802.11A/G. I didn’t really need the wireless “A”, but it should work.

I got the unit home and started to configure it … but then found out that it didn’t support WPA encryption, just WEP. That’s stupid. Half the reason to use 802.11G is to have better encryption.

I bit of searching online and I found that CDW had the D-Link DWL-G820 Wireless Gaming Adapter, 802.11g, 108Mbps. Luckily, there is a BestBuy near CDW.

So off I go to Vernon Hills. I return the Linksys device and go to CDW. Unfortunately, although CDW has the DWL-G820 on site, it’s not off the truck yet. So I have to wait … about 2 hours.

I finally get the new gaming adapter and get it home … it works, although I still haven’t gotten the MediaMVP to work correctly yet. I need to futz with it a bit more.

HAPPY NEW YEAR!

Ok, New Years Eve is over … New Years Day is here. The Covad guy is supposed to be here between 8am and noon. Around 10:45 he calls to say he’s in the city, but on his way out … he should be there a little before noon. That’s refreshing.

He gets here exactly when he said he would … runs a few tests, says “Yeah, the router is fried”. Gets the replacement out and starts to configure it. About 30 minutes later, it’s all configured and we’re back on the air. All I have to do is re-implement my firewall filters. Sure wish I had backed them up a while ago. Oh well, they aren’t that complicated … it’s just a bunch of typing.

It takes me about 2 hours to get the router reconfigured the way it should … then I can get the networking on the linux boxes working again.

All in all, I did a lot of work … but ended up right were I started.

Seems to me that this kind of thing has happened before … a few days off from work, a grand plan to upgrade a system or two, and a bunch of failures that cause nothing but problems.

I’m cursed, I tell you, cursed!

[tags]Linux, MediaMVP, Fedora Core, DLink, Linksys, Covad, DSL, Upgrades, RAID, Wireless[/tags]

Cookout and Archives

Today was a somewhat busy day … went to the annual Broadband Reports Chicago / SBC – Ameritech Midwest Cookout held at kcazzie‘s house.

It was enjoyable … lots of yaking about geeky stuff.

When I got home I started working on implementing a requested feature for the mailing list archives so that the number of results / page could be selected and remembered. Took a few hours to code and test, but it appears to be working well.

I also used the change as an opportunity to change the way the list index pages are generated … now I’m using Jamon … which is a nice templating engine for Java. I’m not using nearly all the capabilities of the package, but I’m pleased with the results.