Activate AHCI in Win 7

Last week I decided to start playing around with Windows 7 on my laptop … just to see how it’s going to work.

Luckily I have a spare SATA hard drive, so there was no risk that I would damage anything permanently.   If the Windows 7 install went bad, I could simply switch back to XP on the original hard drive.

Well, it’s been a little more than a week with Windows 7 and I’m quite impressed.

One thing I noticed is that the hard drive controller wasn’t for the AHCI I thought was configured.   Then I remembered, when I had the motherboard replaced due to the video problems, the default hard drive controller settings would be in place … and the default is to use ATA instead of AHCI.

Theoretically, AHCI should give me better performance than standard ATA.

So today I decided to try and rectify that … a quick Google search turned up this blog that gave a reasonably good writeup on it.

Basically, all you have to do is use regedit and change the ‘start‘ value in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci entry.   The new value should be ‘0’ (zero).     According to this MS knowledge base entry, the driver is disabled in Windows 7 (or Vista) by default … and changing the value to zero re-enables the appropriate driver.

You then have to restart the system a few times.   I tried activating AHCI in BIOS immediately after changing the registry entry, but had loads of problems.   So I did a clean restart, without changing the AHCI in BIOS, then restarted again then changed the BIOS setting, and it worked fine.   I had to restart AGAIN after activating AHCI in BIOS, as Windows needed to load device drivers.

So far so good … although I’m not expecting any problems at this point.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.